GMSGSLAB.DE

Ein Blog über Microsoft Exchange

Exchange Server 2013 und der RecoverServer Mode

Auf ein neues. Lange genug hat es auch gedauert bis wieder ein Eintrag auf meinem Blog erschien. An was hat es denn gelegen. Anfang 2012 kamen die ersten Bits zu Exchange 2013 raus (damals noch Exchange 15) und somit war der Startschuß zum Testen für die Mitglieder des Exchange 15 TAP`s gefallen. Nebenbei dann noch die üblichen Arbeiten im Projekt und ruckzuck, war Exchange 2013 RTM und das Jahr auch schon wieder vorbei.

Kommen wir nun zum wesentlichen Teil meines Blogeintrages. Das Recovern eines Exchange 2013 Servers mittels dem RecoverServer Mode. Wie bereits mit Exchange Server 2010 ist es auch mit Exchange Server 2013 wieder möglich, einen ausgefallenen Server im RecoverServer Mode schnell wieder herzustellen.

Ich möchte hier nun beschreiben, was mir dabei beim Wiederherstellen eines Client Access sowie eines Mailbox Servers passierte.

Wie immer, ein kurzer Hinweis:

Die in diesem Artikel beschriebenen Schritte sowie die daraus resultierenden Screenshots sind alle in meiner virtuellen Testumgebung durchgeführt / erstellt worden.

 

Für meinen Tests hatte ich mir folgende Umgebung aufgebaut:

  • 1 Domänencontroller DC01
  • 1 Exchange Server 2013 mit Client Access und Mailbox Rolle – EX01
  • 1 Exchange Server 2013 mit Mailbox Rolle – EX02
  • 1 Exchange Server 2013 mit Client Access Rolle – EX03

Das Betriebssystem war bei allen Servern Windows Server 2012 in der Standard / Datacenter Version.

 

Für das Recovern des Client Access Servers bin ich wie folgt vorgegangen:

  • Herunterfahren des Servers EX03
  • Rücksetzen des Computer Accounts unter Active Directory Users and Computers
  • Aufsetzen eines neuen Computers, der als Ersatz für den „ausgefallenen“ Server dienen soll (gleicher Name, Installation der benötigten Software für die Client Access Rolle)
  • Aufnehmen des neuen Computers in die Domäne
  • Starten der Installation von Exchange Server 2013 im RecoverServer Mode

Soweit lief alles nach Plan. Bis die Installation kurz vor Schluß mit folgendem Fehler abbrach:

Bei der Installation des Exchange Zertifikats lief etwas schief. Nachdem mir die Fehlermeldung nicht wirklich was sagte, habe ich mir das Exchange Setup Log angesehen um vielleicht mehr darüber zu finden. Leider zwecklos. Auch hier konnte ich nicht die Ursache für den Abbruch finden.

OK, dachte ich mir. Dann lass ich mal den CAS stehen und versuche einen Mailbox Server (Standalone) im RecoverServer Mode wieder herzustellen.

Für das Recovern des Mailbox Servers bin ich wie folgt vorgegangen:

  • Herunterfahren des Servers EX02
  • Rücksetzen des Computer Accounts unter Active Directory Users and Computers
  • Aufsetzen eines neuen Computers, der als Ersatz für den „ausgefallenen“ Server dienen soll (gleicher Name, Installation der benötigten Software für die Mailbox Rolle)
  • Aufnehmen des neuen Computers in die Domäne
  • Starten der Installation von Exchange Server 2013 im RecoverServer Mode

Auch hier zu Beginn alles ohne Probleme. Bis das Setup wieder mit einem Fehler abbrach. Diesmal beschwerte sich das Setup, dass das Laufwerk für die Datenbank und die Logs nicht vorhanden sei. Man muss dazu sagen, dass ich keine Änderung am Standardpfad der Exchange Installation am „ausgefallenen“ Server durchgeführt hatte. Exchange war somit auf C:\… installiert. Laut Fehlermeldung müsste ja dann C:\ nicht vorhanden sein. Was für ein Spass. Das Prüfen des Exchange Setup Logs brachte mich auch nicht weiter.

Nachdem ich nun zwei Server nicht im RecoverServer Mode wiederherstellen konnte, war die Annahme nah, dass es sich hier wohl um sogenannte Bugs handelt. Eine Rückfrage bei Microsoft hat mir das auch bestätigt. Für das Recovern eines Mailbox Servers habe ich auch gleich einen Workaround erhalten, bis das Problem gefixt ist. Das Recovern eines Client Access Servers ist bis auf weiteres im RecoverServer Mode nicht möglich. Der Fix hierzu ist aber auf dem Weg.

Der Workaround für den Mailbox Server ist wie folgt.

  • Erstellen einer Ordnerstruktur inklusive einer Dummy Datei für die Mailbox Datenbank.

Bei einer Standardinstallation wäre das folgender Pfad:

C:\Program Files\Microsoft\Exchange Server\V15\Mailbox\Mailbox Database xxx\Mailbox Database xxx.edb

Die drei xxx dienen als Platzhalter und müssen gegen die korrekte Bezeichnung der Datenbank ausgetauscht werden.

Im Anschluß kann die Installation im RecoverServer Mode nochmal gestartet werden. Der beschriebene Fehler tritt nun nicht mehr auf. Jetzt nur noch die Datenbank aus einer Sicherung zurücksichern.

Dann wollen wir abschließend nur hoffen, dass beide Probleme so schnell wie möglich gefixed werden.

Wie würde Loddar sagen: Again what learned.

In diesem Sinne. Bis zum nächsten Mal.

 

Schreibe einen Kommentar